Kinetic 1.42 GPS is non functional

's Avatar

nick

31 Oct, 2015 02:22 AM

Upgraded to 1.42 and GPS only responds to points where I take out the iPhone and actually look at the Kinetic screen. My normal 3.5 mile walk is now registering as 2.14 miles.

  1. 1 Posted by Don on 01 Nov, 2015 07:50 PM

    Don's Avatar

    Mine stopped working correctly the other day.... gps measures incorrectly.

  2. Support Staff 2 Posted by Nick on 01 Nov, 2015 11:01 PM

    Nick's Avatar

    Hi,

    there is a fix waiting for review.

    Really sorry. In the mean time - please turn off ‘Allow Auto-Lock’ in settings and keep Kinetic in the foreground (battery life will be reduced). Don’t think Auto Lock is strictly necessary (i.e. screen can sleep), as we tested before release, but it does seem if app is not foremost, then this happens...

    Or, If you would like a fix before Apple get around to approving it, you can sign up to be a beta tester? Please provide your apple iTunes email if so, and we can add you.

    Best Regards

    Nick

  3. 3 Posted by nick on 02 Nov, 2015 09:07 PM

    nick's Avatar

    I tried running with ‘Allow Auto-Lock’ off, and the app in the foreground,
    and still only got the app to register the GPS position when I stopped and
    looked at the screen.

    iPhone is: 5S 32GB

    If you still need beta testers my Apple iTunes email is: [email blocked]

    Nick

  4. 4 Posted by Steve on 03 Nov, 2015 08:01 AM

    Steve's Avatar

    Kinetic has fouled up 2 runs for me now. One of them was the first run I did with my wife, what fanastic timing that was for a complete meltdown in the app. If I don't hear the kilometer announcement when I expect it then I have to stop to mess around with the app and that it my run screwed up around kilometre run. I pushed on for another 1/2 k or so and it appears that the latest release is recording miles as kilometres. So I would have to run 5 miles to record 5km. After the last foul-up I restarted the phone in case that was the problem, nope, another run screwed.

    I have been using Kinetic since January 2014 for walking and now running. The distances I have covered are a personal record and I use them for motivation. When walking I recorded in imperial units, now I am running I use metric as it is easier to get confirmations every 1km.

    Kinetic was in the foreground for part of the run, I don't use auto lock and I am not convinced you know what the problem is. iPhone 6s+ 128GB.

    How can you release the software when it doesn't perform its primary function? Did you test it at all? I am really flipping angry about this. I feel betrayed by an app I have recommended to other people.

  5. Support Staff 5 Posted by Nick on 03 Nov, 2015 08:27 AM

    Nick's Avatar

    Hi Steve,

    Auto lock is a setting in the settings section and when off, the screen should not go to sleep - in this case kinetic should perform as expected (though obviously is not ideal for most people).

    We are confident we know what the issue is, and that we have a fix waiting for review.

    We can only apologise at this point.

    Regards

    Nick

  6. 6 Posted by Ted on 03 Nov, 2015 03:00 PM

    Ted's Avatar

    Exact same situation as Steve mentions above. Not only does Kinetic stop announcing my lap times, it also stops the music I have playing. Why would you release a version of software so flagrantly inept? Does being fast out the door with this crap sandwich of an upgrade really serve your client base? Congratulations on knowing what the issue is. When do you expect to release the fix?

  7. Support Staff 7 Posted by Nick on 03 Nov, 2015 03:15 PM

    Nick's Avatar

    the fix is released to apple and out of our hands - they normally take 1-2 weeks!

    We could add you as a beta tester if you would like the release earlier?

    please provide your iTunes account email to be added to the beta.

    Regards

    Nick

  8. 8 Posted by Steve Bolton on 06 Nov, 2015 09:24 AM

    Steve Bolton's Avatar

    Took the first beta fix, had a footle around in the settings and turned off Auto Lock. (I must also have toggled default units. Went for a run and very happy to hear the first KM voice prompt at the correct distance. Huge relief as I had taken a look at other GPS apps and was not impressed with any of them.

    Take the second beta update which fixes startup crashes. Testflight says I am running 1.43 (2263). Go for another run with confidence. Get past the first kilometer no report. Oh **** not again! Stop run to fiddle with the app including pressing STOP. Kinetic thinks I have run .47KM. I fiddled with the distance units convinced that it was recording in miles and reporting them as kilometres. For the rest of the run the kilometer markers came up as expected so I started to write this post convinced I knew the answer.

    Looking at the GPS track on Google maps Kinetic only recorded the Data point where I pressed start and then the first stop. So the first part of the run is a direct line between the two points. The rest of the run Kinetic must have stayed in the foreground and recorded the GPS data correctly.

    This is simply not acceptable, more data lost by Kinetic. I don't want to have to monitor the app to check it is in the foreground. Anyway you don't have a fix for the reliability issue with the latest beta and probably not the previous one. I run the same route every time. IMG_7569.png is this morning's screw-up, IMG_7570.png is yesterday's correct track for the route.

  9. 9 Posted by Steve Bolton on 06 Nov, 2015 09:27 AM

    Steve Bolton's Avatar

    Just written a long post with two attachments and it is not appearing. This is a test.

  10. Support Staff 10 Posted by Nick on 06 Nov, 2015 09:35 AM

    Nick's Avatar

    Hi Steve,

    Sorry you have lost more data. This looks like Kinetic did not get a GPS lock before the app was put into the background...

    Will look into how this can happen. Thanks for the report...been working reliably for everyone else.

    Please make sure you have a good GPS signal before pressing start and turning off the screen (i understand this is not ideal - and will look into, a lot of things changed behaviourally with the GPS in iOS9 SDK).

    Best Regards

    Nick

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac